Trying to record a nav/search web script for Captaris (OpenText) Alchemy 8.2 document management software. After searching for content you can click on an item and it opens the .RSF in the Alchemy Internal Viewer.

The request looks like this:



The problem is I cannot find the .RSF file name in any response and the first time I see it in the replay log or code gen log is after it was parsed in the request.

I have tried with IE6 and IE8 and with both Vugen 9.52 and 11.52 in all recording modes and several different protocols, toggling all sorts of recording options and all with the same result.

I did try using Firefox 25 which is not functional enough for me to record the entire script but I was able to record a piece that in Vugen looks like a clue:

<SCRIPT SRC='Scripts/FirstVwr.js'></SCRIPT><SCRIPT>parent.HidePrintButton( );
GenerateObjectContent(1, "Components/FirstVwr.CAB#Version=8,2,103,415", "%40%40%3cRSF%3e%3cSRC%3e*%23IMRWViewer%2fDoc% 2f


%3c%2fSRC%3e%3cFormat%3e4%3c%2fFormat%3e%3cTitle%3 e55PHF117599%3c%2fTitle%3e%3cDocFileName%3e000APLI NSTV1.pdf%3c%2fDocFileName%3e%3cOptions%3e%3cDisab leScan%2f%3e%3c%2fOptions%3e%3cDocUpdateUrl%3eUpda teDocument.ashx%3fParms%3dQUFSUCAvIEFCVSBOUSBEb2N1 bWVudHMgMQ%253d%253d%257cMjk%253d%3c%2fDocUpdateUr l%3e%3cCanAnnotate%2f%3e%3cIsReadOnly%2f%3e%3c%2fR SF%3e");</SCRIPT>

It appears that the JavaScript ďFirstVwr.js'Ē calls the requested RSF file in a function somehow that must not be visible to Vugen when recorded in IE. I imagine itís something client side or async back to the server. Since I canít record the full script in Firefox, how can I go about capturing this value? I donít want to get a small list of file names from the app owner and parameterize it, Iíd rather be able to properly return the value so the script will be more robust and realistic. I tried searching through several of the HP Vugen/PC PDFs but nothing there seem to fit. I can open a ticket with HP and I can contact the Alchemy vendor too, but not sure the response will be as fast or accurate as it would be here.

Any thoughts on how to tackle the problem? Below is the request that first calls the FirstVwr.js file.

Thanks in advance!

************************************************** ******
"Referer=http://alchemy/alchemyweb/WaitPage.aspx?Parms=UEkgLyBBQlUgRXhwaXJlZCBBdXRvIF BvbGljaWVzIDI%3d%7cNDI4MTY2MA%3d%3d%7cMDFQSCAxMDM5 MzE%3d%7cQ2xvc2U%3d%7c",

"URL=http://alchemy/alchemyweb/ViewItemPageContents.aspx?Parms=UEkgLyBBQlUgRXhwaX JlZCBBdXRvIFBvbGljaWVzIDI%3d%7cNDI4MTY2MA%3d%3d%7c MDFQSCAxMDM5MzE%3d%7cQ2xvc2U%3d%7c&key=x1058A0A75D E623FC386C16CA2BF7EDC7",
"Referer=http://alchemy/alchemyweb/ViewItemPage.aspx?Parms%3DUEkgLyBBQlUgRXhwaXJlZCBB dXRvIFBvbGljaWVzIDI%3D%7CNDI4MTY2MA%3D%3D%7CMDFQSC AxMDM5MzE%3D%7CQ2xvc2U%3D%7C",
************************************************** *******