SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    May 2011
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    web_reg_find registers successful but no SaveCount

    I've been using web_reg_find for a while now and it has been working fine for me, Except For This Case: I'm doing a search on a webpage and the search result shows up in a webtable. Replay log shows that web_reg_find registers successful, but no savecount is saved. Also there is a warning of pending web_reg_save_param.

    Any ideas why? (LR 9.5, Web(Click and Script) protocol)

    ===============================
    Vuser Code:
    ===============================
    web_reg_find("Text=ETCI",
    "SaveCount=ID_Count",
    LAST);

    web_button("INPUT_2",
    "Snapshot=t7.inf",
    DESCRIPTION,
    "Type=button",
    "Tag=INPUT",
    "ID=",
    "Name=search",
    "Value=Search",
    "Ordinal=1",
    ACTION,
    "UserAction=Click",
    LAST);

    lr_start_transaction("Search");

    if (atoi(lr_eval_string("{ID_Count}")) >0 ) {
    lr_output_message("patient search ok.");
    lr_end_transaction("Search", LR_PASS);
    }
    else{
    lr_output_message("patient search failed.");
    lr_end_transaction("Search", LR_FAIL);
    }

    ========================================
    in replay log:
    ========================================
    ction.c(107): Warning -26379: Pending web_reg_save_param/reg_find/create_html_param[_ex] request(s) are deleted and will be handled as "not found" [MsgId: MWAR-26379]
    Action.c(107): Registered web_reg_find successful for "Text=ETCI" [MsgId: MMSG-26362]
    Action.c(107): web_button("INPUT_2") highest severity level was "warning" [MsgId: MMSG-26391]
    Action.c(120): Notify: Transaction "Search" started.
    Action.c(127): patient search failed.
    Action.c(128): Notify: Transaction "Search" ended with "Fail" status (Duration: 0.0061).

  2. #2
    Moderator
    Join Date
    Aug 2001
    Location
    NC
    Posts
    6,018
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Total Downloaded
    0

    Re: web_reg_find registers successful but no SaveCount

    whether web_reg_find() operates successfully is distinct and different from whether the item being searched for exists. web_reg_find() belongs to a class of functions called service functions which can operate with success even whether the action called for by the function returns a failure. Web_reg_save_param() is another example of a service function.

    It looks like the page you expected to be returned has not been. In fact, I would suspect that the web_button you expect to be present may not be.
    James Pulley

    Replace ineffective offshore contracts, LoadRunnerByTheHour. Starting @ $19.95/hr USD.

    Put us to the test, skilled expertise is less expensive than you might imagine.

    Twitter: @LoadRunnerBTH @PerfBytes

  3. #3
    Junior Member
    Join Date
    May 2011
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: web_reg_find registers successful but no SaveCount

    You are right. Although the button shows in tree view of vuser script as "Button["INPUT_2").UserAction("Click")", and it is also highlighted in page view, but it seems that the "Click" action has never been performed.

    Now my question becomes: why the click doesn't work?

  4. #4
    Junior Member
    Join Date
    May 2011
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: web_reg_find registers successful but no SaveCount

    James,
    I've noticed that there are a whole bunch of javascript warnings before and after web_reg_find():

    Action.c(107): Warning -26276: JavaScript error (id=39) in line 250: TypeError: document.getElementById("formMenu") has no properties [MsgId: MWAR-26276]
    Action.c(107): Warning -26276: JavaScript error (id=0) in line 1: JavaScript evaluation error when executing function (by pointer) [MsgId: MWAR-26276]
    Action.c(107): Warning -26000: Evaluating decompiled script failed for "DIV" DOM element (name="") "mousedown", listed in the following line: [MsgId: MWAR-26000]
    Action.c(107): Warning -26000: fMenuHide(); [MsgId: MWAR-26000]
    Action.c(107): Warning -26276: JavaScript error (id=39) in line 70: TypeError: window.FORM has no properties [MsgId: MWAR-26276]
    Action.c(107): Warning -26276: JavaScript error (id=0) in line 1: JavaScript evaluation error when executing function (by pointer) [MsgId: MWAR-26276]
    Action.c(107): Warning -26000: Evaluating decompiled script failed for "INPUT" DOM element (name="search") "click", listed in the following line: [MsgId: MWAR-26000]
    Action.c(107): Warning -26000: handleGridSearch(); [MsgId: MWAR-26000]
    Action.c(107): Warning -26379: Pending web_reg_save_param/reg_find/create_html_param[_ex] request(s) are deleted and will be handled as "not found" [MsgId: MWAR-26379]
    Action.c(107): Registered web_reg_find successful for "Text=ETCI" [MsgId: MMSG-26362]
    Action.c(107): web_button("INPUT_2") highest severity level was "warning" [MsgId: MMSG-26391]
    Action.c(120): Notify: Transaction "Search" started.
    Action.c(127): patient search failed.
    Action.c(128): Notify: Transaction "Search" ended with "Fail" status (Duration: 0.0066).
    Action.c(131): Warning -26276: JavaScript error (id=39) in line 250: TypeError: document.getElementById("formMenu") has no properties [MsgId: MWAR-26276]
    Action.c(131): Warning -26276: JavaScript error (id=0) in line 1: JavaScript evaluation error when executing function (by pointer) [MsgId: MWAR-26276]
    Action.c(131): Warning -26000: Evaluating decompiled script failed for "DIV" DOM element (name="") "mousedown", listed in the following line: [MsgId: MWAR-26000]
    Action.c(131): Warning -26000: fMenuHide(); [MsgId: MWAR-26000]

  5. #5
    Advanced Member
    Join Date
    Jun 2006
    Location
    USA
    Posts
    785
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: web_reg_find registers successful but no SaveCount

    Object properties during replay must be same as the one used during record. in your case

    "Type=button",
    "Tag=INPUT",
    "ID=",
    "Name=search",
    "Value=Search",
    "Ordinal=1",

    The above should all match. Even if one property changes, it will fail. To make the script robust, look if the input button has an id and populate the ID field in the script

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 10.71%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 02:33 AM.

Copyright BetaSoft Inc.