SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 7 of 7
  1. #1
    Senior Member
    Join Date
    Dec 2002
    Location
    france
    Posts
    183
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Setting the parameter file

    Hi;

    I use a data file which contains 30000 elements but when I execute the load test, I have the following error with only 1200 elements used :

    No more unique values for this parameter in table '..\..\Jdd\Comet_TMC_D1.txt' [unique range is 1101-1200].The parameter continues with last value of the range according to "When Out Of Values" policy.

    Setting the parameter type file :

    Select nex row : Unique
    Update Value on : each iteration
    When out of values : Continue in a cyclic manner

    How I set the parameter file for using all 30000 elements into the file without any error ?
    Total : the load test must used about 28000 elements.

    Regards

  2. #2
    Member
    Join Date
    Jun 2010
    Location
    India
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Setting the parameter file

    Please if there are any carriage returns in the middle of the file. Sanitize the file once and try it.
    Cheers,
    <font color="red">KK</font>
    <font color="blue">Any computer is as dumb as its user</font>
    http://in.linkedin.com/pub/kranthi-paidi/1a/b62/758

  3. #3
    Senior Member
    Join Date
    Dec 2002
    Location
    france
    Posts
    183
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Setting the parameter file

    OK I have verify but my settings are corrects :

    Select nex row : Unique
    Update Value on : each iteration
    When out of values : Continue in a cyclic manner

  4. #4
    Moderator
    Join Date
    Jan 2006
    Location
    Charlotte, NC
    Posts
    1,600
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Setting the parameter file

    One thing to be aware of is that the Controller uses different math than you and I. I have a file of 200 entries with 10 Vusers. That to me means 10 per. That's not necessarily what the Controller is going to figure!

    What I have done in the past is tell the Controller exactly how many values to give to each Vuser.
    Unless you are writing a compiler, strtok is NOT the answer.
    See: http://www.sqaforums.com/showflat.ph...=541641#542222

    QAF is still an exercise in self-sufficiency! (Thank JB!)

  5. #5
    Member
    Join Date
    Feb 2005
    Location
    New York
    Posts
    395
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    1 Thread(s)
    Total Downloaded
    0

    Re: Setting the parameter file

    as i recall, there is a limit of the number of rows in the datafile, i don't think its 1200, but i am sure its much less than 3000

  6. #6
    Member
    Join Date
    Apr 2008
    Posts
    68
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Setting the parameter file

    Agreed, best practice is to manually configure how many rows are allocated to each user, that way you will have no surprises with regard to allocation of the data.
    Barry Perez
    Melbourne, Australia

    My LinkedIn

  7. #7
    Member
    Join Date
    Jul 2002
    Location
    Moline,IL
    Posts
    208
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Setting the parameter file

    How many users and how many iterations did you have it setup for? Based on your settings you have to multiply the users * the # of iterations and that will give you the number of lines you need.

    Note - if doing a 'manual' increase of the users it does not seem to work properly. As mentioned it is best to force a certain number of rows per user if running manually. The auto-majic logic seems to fail if you manually ramp up.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 9.38%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 08:06 PM.

Copyright BetaSoft Inc.