I'm currently looking at performance testing a mobile web site, that has been manually tested using firefox and changing the user agent to "iphone"

the site appears to work ok (well apart from a few functional issues - which won't be a problem in LR once the scripts are working)

first script I managed to record with LR ok

script is open app, select language, request message via sms

second script can't get it to record at all - just left with my comments in the script

checked the recording options in both scripts - made sure 2nd was fine and tried again - same issue

copied 1st script and try to record 2nd over it (in case I've missed something)

try creating script from scratch using fiddler record

used web_set_user() and web_add_auto_header() to make sure I'm being authenticated in the LDAP and that I have the user agent set correctly - neither script will replay - I get the following error

Error -27796:Failed to connect to server "Server:443": (10065) No Route To Host

and returns 0 header bytes and 0 body bytes

works fine in the browser, though

it's not working through WAP protocol (doesn't use WAP) it's a standard web site that only works with mobile user-agents)

I've tried just about every sensible protocol/recording method except winsock

anybody out there got any ideas?