SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 10 of 10
  1. #1
    Member
    Join Date
    Oct 2006
    Posts
    59
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Parameter Submit not working

    Hi,

    I am trying to refresh a Search page with some Prior dates from OCT 2008. I have created a Parameter {Start Date} for the date field in the script and provided the dates in a List for the parameter to be selected Randomly each iteration. When i replay the script the script is not capturing the dates from the Parameter file instead using the same Dates from the recording. I have correlated the script too. I am posting the web_Submit part of the script below. Can some one please let me know if i need to parameterize anything else.

    web_submit_data("HourlyPoolSettlementFilesViewer.a spx_2",
    "Action=http://settlementcentral1-t/WPS/ContentPages/HourlyPoolSettlementFilesViewer.aspx",
    "Method=POST",
    "TargetFrame=",
    "RecContentType=text/html",
    "Referer=http://settlementcentral1-t/WPS/ContentPages/HourlyPoolSettlementFilesViewer.aspx",
    "Snapshot=t3.inf",
    "Mode=HTML",
    ITEMDATA,
    "Name=__pageKey", "Value={WCSParam_Diff1}", ENDITEM,
    "Name=__EVENTTARGET", "Value=ctl00$cphBody$wdcStartDate", ENDITEM,
    "Name=__EVENTARGUMENT", "Value=ValueChanged:{StartDate}", ENDITEM,
    "Name=__VIEWSTATE", "Value={WCSParam_Diff2}", ENDITEM,
    "Name=__VIEWSTATEENCRYPTED", "Value=", ENDITEM,
    "Name=__EVENTVALIDATION", "Value={WCSParam_Diff3}", ENDITEM,
    "Name=ctl00_cphBody_wdcStartDate_DrpPnl_Calendar1" , "Value=<x%20PostData%3D"2009x3x-1x-1x-1"></x>", ENDITEM,
    "Name=ctl00$cphBody$wdcStartDate_hidden", "Value=<DateChooser%20Value%3D"2008x10x1">&l t;/DateChooser>", ENDITEM,
    "Name=ctl00_cphBody_wdcStartDate_input", "Value={StartDate}", ENDITEM,
    "Name=ctl00$cphBody$ddlStartHE", "Value=1", ENDITEM,
    "Name=ctl00_cphBody_wdcEndDate_DrpPnl_Calendar 1", "Value=<x%20PostData%3D"2009x3x-1x-1x-1"></x>", ENDITEM,
    "Name=ctl00$cphBody$wdcEndDate_hidden", "Value=<DateChooser%20Value%3D"2009x2x28">&l t;/DateChooser>", ENDITEM,

    "Name=ctl00_cphBody_wdcEndDate_input", "Value={EndDate}", ENDITEM,
    "Name=ctl00$cphBody$ddlEndHE", "Value=24", ENDITEM,
    EXTRARES,
    "URL=../WebResource.axd?d=ehoTtlE4jYepCfBxLaZJEA2&t=63 3655475742914851", ENDITEM,
    "URL=../WebResource.axd?d=1JOZnOM2NUksIrFnhCPzKw2&t=63 3655475742914851", ENDITEM,
    "URL=../WebResource.axd?d=VcGjb-adZhtaKEZ7rmqTZvq5v0e7LOLTIA-Cl6ykYV3EgrUmvvnkEp6C7OUhF-g4jnCZ7RN5F8ccNvKNBCy6ZsYjEsK3W3pdFp0zBgQwINoHxDJM KJjIr22RknN5Ff770&t=633645292680000000", ENDITEM,
    "URL=../App_Themes/WPSTheme/Images/ig_cal_blue2.gif", ENDITEM,
    "URL=../App_Themes/WPSTheme/Images/ig_cal_blue1.gif", ENDITEM,
    LAST);


    Thanks,
    Vineel.

  2. #2
    Moderator JakeBrake's Avatar
    Join Date
    Dec 2000
    Location
    St. Louis - Year 2025
    Posts
    15,609
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Parameter Submit not working


  3. #3
    Member
    Join Date
    Oct 2006
    Posts
    59
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Parameter Submit not working

    Hi,

    Sorry for the vague post there.

    1. What version of LoadRunner (LR) or PerformanceCenter (PC) are you using? (specify which tool LR or PC)
    LR 9.1

    2. What is the protocol you are recording?
    Tried Web (HTTP/HTML) and webwinsock dual protocol

    2.1 If .NET, which version of .NET does the app require?
    3.0

    2.2 If .NET, which version of .NET do you have installed?

    2.3 If OracleNCA with Oracle Forms Server, please list the version of Oracle Forms Server. You can get this info from the main Oracle Form when launched - Help -> About
    N/A

    3. If HTML - are you using HTML-Advanced with URLs or,
    (indicate yes/no)
    No

    4. If URL mode:
    - Concurrent groups, or
    - Without Concurrent groups?
    Concurrent groups

    5. Which LoadRunner/PerformanceCenter feature (FPs) or service packs are you using?
    LR 9.0

    6. VuGen Recording - are you using Old or New Recording Engine?
    used Old too

    7. You must list here the specifc Licensed Vuser type for your specific issue AND the license amount you have for this Vuser protocol - per the example below (Unlimited, Permanent, N/A, etc. are not options) .

    Permanent

    8. Is your support/maintenance contract current and active?
    (substitute your answer here - Yes or No)
    Yes

    9. What platform(s) (PCs) and Operating Systems (Windows-XP, etc.) are being used for load generators and controllers? Include version and service packs (SP1 or 2, etc.)
    Win server 2000 SP2 for controller
    win xp Loadgenerators


    10. If you have filed a service request with HP/Mercury, what have they told you at this point with respect to your issue?
    Yes still waiting response from the support personnel.

  4. #4
    Moderator JakeBrake's Avatar
    Join Date
    Dec 2000
    Location
    St. Louis - Year 2025
    Posts
    15,609
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Parameter Submit not working

    We are sticklers here! [img]/images/graemlins/wink.gif[/img]

    7. You must list here the specifc Licensed Vuser type for your specific issue AND the license amount you have for this Vuser protocol - per the example below <font color="red"> (Unlimited, Permanent, N/A, etc. are not options)</font> .

    Tuxedo / 9,876
    Oracle NCA / 1,234

  5. #5
    Member
    Join Date
    Oct 2006
    Posts
    59
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Parameter Submit not working

    Hi,

    We have a Permanent licenses. Validity Unlimited,
    web &amp; Multimedia 1500
    Network Bundle 250
    DB Bundle 250
    SOA bundle 250

    Thanks,
    Vineel.

  6. #6
    Moderator JakeBrake's Avatar
    Join Date
    Dec 2000
    Location
    St. Louis - Year 2025
    Posts
    15,609
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Parameter Submit not working

    It appears that both parameterization and correlation are in order. Also, you need to discover the impact of instances of hardcoded values such as the values associated with these, "WebResource.axd?d="

    You wiil need to work with your app team to see what needs to be parameterized beyond what is already apparent - as we cannot know the business rules with respect to impact of hardcoded values. The general rule of thumb is to thoroughly parameterize and correlate.

  7. #7
    Moderator
    Join Date
    Jan 2006
    Location
    Charlotte, NC
    Posts
    1,600
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Parameter Submit not working

    Record twice and diff. This is the starting point for every script to answer the question "Can some one please let me know if i need to parameterize anything else."
    Unless you are writing a compiler, strtok is NOT the answer.
    See: http://www.sqaforums.com/showflat.ph...=541641#542222

    QAF is still an exercise in self-sufficiency! (Thank JB!)

  8. #8
    Senior Member
    Join Date
    Nov 2007
    Location
    Bangalore,India
    Posts
    166
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Parameter Submit not working

    Hello Vineel,

    I am sorry to say this but its a hard fact! [img]/images/graemlins/smile.gif[/img] you have missed parametrizing the dates!!

    Observe the below lines in your code:
    "Name=ctl00_cphBody_wdcStartDate_DrpPnl_Calendar1" , "Value=&lt;x%20PostData%3D"2009x3x-1x-1x-1"&gt;&lt;/x&gt;", ENDITEM,

    "Name=ctl00$cphBody$wdcStartDate_hidden", "Value=&lt;DateChooser%20Value%3D"2008x10x1"&gt;&l t;/DateChooser&gt;", ENDITEM,

    "Name=ctl00_cphBody_wdcEndDate_DrpPnl_Calendar 1", "Value=&lt;x%20PostData%3D"2009x3x-1x-1x-1"&gt;&lt;/x&gt;", ENDITEM,

    "Name=ctl00$cphBody$wdcEndDate_hidden", "Value=&lt;DateChooser%20Value%3D"2009x2x28"&gt;&l t;/DateChooser&gt;", ENDITEM,

    Observe the value 2008x10x1 in the second line above which appears to be the date range that you are searching for. This needs to be parametrized for it to fetch the right data for you. You can parametrize the day,month and year seperately or write a C code to get the complete date from your parameter and append the x wherever required.

    Hope this helps!!

    Thanks
    Prashanth

  9. #9
    Senior Member
    Join Date
    Nov 2007
    Location
    Bangalore,India
    Posts
    166
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Parameter Submit not working

    The date values I pointed above might need to be correlated rather than parametrised. check your server response and modify your script accordingly.

    Thanks
    Prashanth T

  10. #10
    Member
    Join Date
    Oct 2006
    Posts
    59
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Parameter Submit not working

    Thanks for the quick replies.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 10.71%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 02:21 PM.

Copyright BetaSoft Inc.