Results 1 to 5 of 5
  1. #1

    No Response Body in Generation Log

    1. What version of LoadRunner (LR) or PerformanceCenter (PC) are you using? (specify which tool LR or PC)
    VuGen for Performance Centre 9.1

    2. What is the protocol you are recording?

    2.1 If .NET, which version of .NET does the app require?

    2.2 If .NET, which version of .NET do you have installed?

    2.3 If OracleNCA with Oracle Forms Server, please list the version of Oracle Forms Server. You can get this info from the main Oracle Form when launched -

    Help -> About

    3. If HTML - are you using HTML-Advanced with URLs or,
    Tried using both options

    4. If URL mode:
    - Concurrent groups, or
    - Without Concurrent groups?
    Tried using both option

    5. Which LoadRunner/PerformanceCenter feature (FPs) or service packs are you using?

    6. VuGen Recording - are you using Old or New Recording Engine?
    New Recording engine

    7. List here the Licensed Vuser type/ quantity that you are/were using for this specific issue /problem.

    8. Is your support/maintenance contract current and active?
    Yes support current

    9. What platform(s) (PCs) and Operating Systems (Windows-XP, etc.) are being used for load generators and controllers? Include version and service packs (SP1

    or 2, etc.)
    Only recording on local pc using Vugen at the moment so not relevant. not using load generators or controllers.
    local pc Windows XP

    10. If you have filed a service request with HP/Mercury, what have they told you at this point with respect to your issue?
    not logged with HP yet

    I am recording a script for an application under test. The application is Java Swing thick client launched from a .bat file. The protocol is http with hex

    messages. The application communicates with an apache webserver which is loadbalanced. Webserver OS is linux.

    After i complete the recording and generate the script when i look in the generation log the response body has not recorded properly. Below is an example of

    how it is displayed.

    ****** Response Body For Transaction With Id 5 ******

    $$$$$$ Response Body For Transaction With Id 5 Ended $$$$$$

    If I play back the script with Run-time Settings>Data return from server selected, the response body is displayed correctly in the replay log.

    Action.c(45): t=2379ms: 4229-byte chunked response body for "http://XXXXX.com/XXXX/XXXXX" (RelFrameId=1, Internal ID=3)
    Action.c(45): \xAC\xED\x00\x05sr\x00*XXX.shared.transport.Transm issionResponseI\x9Ah\xCAZ\xFDY\x86\x02\x00
    Action.c(45): \x07I\x00\x08lastNodeI\x00\tsessionIDJ\x00\ttimeSt ampL\x00\x0EchangedClassest\x00\x12Ljava
    Action.c(45): /util/BitSet;L\x00\x0FremoteExceptiont\x00\x15Ljava/lang/Throwable;L\x00\x0EresponseObject
    Action.c(45): t\x00\x12Ljava/lang/Object;L\x00\x0EresponseVectort\x00\x12Ljava/util/Vector;xr\x00" ........

    Can anyone advise me why the response body is not displayed in the generation log? Can any one tell me how to get the response body to show in the

    generation log?

    I have tried recording with HTML Advanced>A script describing user actions
    HTML Advanced>A script containing explicit urls only
    Record within the current script step
    Record in separate steps and use concurrent groups
    Http Properties>Advanced>Recording schemes>No exclusions

    The reason i need to see the generation log is to try and correlate the dynamic data in the script so it will playback. It isn't possible to correlate from

    the playback log, i need to be able to see the request and response from the generation log.

  2. #2

    Re: No Response Body in Generation Log

    If you want response body, it will be available in tree veiw also, under Server response when you select a url.

    To my understaning there is no setting for generation log, it is handled internally by Loadruner. Hope you tried recording more than once.

    Zubair Syed

  3. #3

    Re: No Response Body in Generation Log

    Unfortunately the Hex message does not format correctly in the tree view so isn't usable. Many of the characters are missing.

  4. #4

    Re: No Response Body in Generation Log

    Try doing a WinSock record. That may capture the return data for you in a semi-useful form.
    Unless you are writing a compiler, strtok is NOT the answer.
    See: http://www.sqaforums.com/showflat.ph...=541641#542222

    QAF is still an exercise in self-sufficiency! (Thank JB!)

  5. #5

    Re: No Response Body in Generation Log

    Thanks for you advice it was a great help. Recorded a script in winsock and the return from server was displayed, therefore I was able to correlate. Then I was able to create an http protocol script using the same correlation. Thanks.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
BetaSoft Inc.
All times are GMT -8. The time now is 07:49 PM.

Copyright BetaSoft Inc.