SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Oct 2008
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    HTTP status code=500 (Internal Server Error)

    1. What version of LoadRunner (LR) or PerformanceCenter (PC) are you using?
    LR 8.1.

    2. What is the protocol you are recording?
    HTTP/HTML.


    3. If HTML - are you using HTML-Advanced with URLs or,
    (indicate yes/no)--

    No.

    4. If URL mode:
    - Concurrent groups, or
    - Without Concurrent groups?

    N.A.

    5. Which LoadRunner/PerformanceCenter feature (FPs) or service packs are you using?

    FP4.

    6. VuGen Recording - are you using Old or New Recording Engine?

    Not sure.

    7. What kind of LoadRunner license do you have -
    - Subscription,
    - Perpetual,
    - Permanent/Unlimited
    - Virtual User days, or
    - Evaluation?
    (choose the one that fits your license model - (substitute your answer here))

    Permanent

    8. If subscription, is subscription current or expired?
    (substitute your answer here)
    N.A

    9. What platform(s) (PCs) and Operating Systems (Windows-XP, etc.)? Include version and service packs (SP1 or 2, etc.)

    Win 2000 SP3.

    10. If you have filed a service request with HP/Mercury, what have they told you at this point with respect to your issue?
    (substitute your answer here)

    No.

    -----------------------------------------------------------

    Hi All,

    I receive the HTTP Status code=500 (Internal Server Error) when i replay a recorded script. I'm using the web_custom_request and Method=POST to call a web service.

    Below is the script:
    ------------------------------------
    Action()
    {
    web_custom_request("WebService_4",
    "URL=http://localhost:8081/axis2/services/WebService",
    "Method=POST",
    "TargetFrame=",
    "Resource=0",
    "RecContentType=multipart/related",
    "Referer=",
    "Snapshot=t17.inf",
    "Mode=HTML",
    "EncType=multipart/related; boundary=MIMEBoundaryurn_uuid_3350823C971244E19412 23348551434; type=\"application/xop+xml\"; start=\"0.urn:uuid:3350823C971244E1941223348551435 @apache.org\"; start-info=\"application/soap+xml\"; action=\"putFile\"",
    LAST);


    return 0;
    }
    ----------------------------------------------------------

    Below is the extended log
    -----------------------------------------------------------
    Running Vuser...
    Starting iteration 1.
    Starting action Action.
    Action.c(6): web_custom_request("WebService_4") started [MsgId: MMSG-26355]
    Action.c(6): t=490ms: Connecting to host 127.0.0.1:8081 [MsgId: MMSG-26000]
    Action.c(6): t=496ms: Connected socket from 127.0.0.1:27030 to 127.0.0.1:8081 in 4 ms [MsgId: MMSG-26000]
    Action.c(6): t=498ms: 380-byte request headers for "http://localhost:8081/axis2/services/WebService" (RelFrameId=1)
    Action.c(6): POST /axis2/services/WebService HTTP/1.1\r\n
    Action.c(6): Content-Type: multipart/related; boundary=MIMEBoundaryurn_uuid_5D86E2EADFC50DBA8212 2353555
    Action.c(6): 0271; type="application/xop+xml"; start="0.urn:uuid:5D86E2EADFC50DBA821223535550272@ apache
    Action.c(6): .org"; start-info="application/soap+xml"; action="putFile"\r\n
    Action.c(6): User-Agent: Axis2\r\n
    Action.c(6): Accept: */*\r\n
    Action.c(6): Connection: Keep-Alive\r\n
    Action.c(6): Host: localhost:8081\r\n
    Action.c(6): Content-Length: 0\r\n
    Action.c(6): \r\n
    Action.c(6): t=909ms: 429-byte response headers for "http://localhost:8081/axis2/services/WebService" (RelFrameId=1)
    Action.c(6): HTTP/1.1 500 Internal Server Error\r\n
    Action.c(6): Server: Apache-Coyote/1.1\r\n
    Action.c(6): Content-Type: multipart/related; boundary=MIMEBoundaryurn_uuid_68451DA92FDB4CD1DE12 2356488
    Action.c(6): 3340; type="application/xop+xml"; start="0.urn:uuid:68451DA92FDB4CD1DE1223564883341@ apache
    Action.c(6): .org"; start-info="application/soap+xml"; action="http://www.w3.org/2005/08/addressing/soa
    Action.c(6): p/fault"\r\n
    Action.c(6): Transfer-Encoding: chunked\r\n
    Action.c(6): Date: Thu, 09 Oct 2008 15:07:30 GMT\r\n
    Action.c(6): Connection: close\r\n
    Action.c(6): \r\n
    Action.c(6): t=964ms: 5-byte chunked response overhead for "http://localhost:8081/axis2/services/WebService" (RelFrameId=1)
    Action.c(6): 33a\r\n
    Action.c(6): t=970ms: 590-byte chunked response body for "http://localhost:8081/axis2/services/WebService" (RelFrameId=1)
    Action.c(6): --MIMEBoundaryurn_uuid_68451DA92FDB4CD1DE12235648833 40\r\n
    Action.c(6): Content-Type: application/xop+xml; charset=UTF-8; type="application/soap+xml"\r\n
    Action.c(6): Content-Transfer-Encoding: binary\r\n
    Action.c(6): Content-ID: <0.urn:uuid:68451DA92FDB4CD1DE1223564883341@apa che.org>\r\n
    Action.c(6): \r\n
    Action.c(6): <?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope xmlns:soapenv="http://www.w3.org/2
    Action.c(6): 003/05/soap-envelope" xmlns:wsa="http://www.w3.org/2005/08/addressing"><soapenv:Header><ws
    Action.c(6): a:Action>http://www.w3.org/2005/08/addressing...der><soa
    Action.c(6): penv:Body><soapenv:Fault><soapenv:Code ><soapenv:Value>soapenv:Receiver</soapenv
    Action.c(6): t=1110ms: 236-byte chunked response body for "http://localhost:8081/axis2/services/WebService" (RelFrameId=1)
    Action.c(6): :Value></soapenv:Code><soapenv:Reason><soapenv: Text xml:lang="en-US">Mime parts not found.
    Action.c(6): Stream ended while searching for the boundary</soapenv:Text></soapenv:Reason><soapenvet
    Action.c(6): ail /></soapenv:Fault></soapenv:Body></soapenv:Envelope>
    Action.c(6): t=1125ms: 6-byte chunked response overhead for "http://localhost:8081/axis2/services/WebService" (RelFrameId=1)
    Action.c(6): \r\n
    Action.c(6): 38\r\n
    Action.c(6): t=1134ms: 56-byte chunked response body for "http://localhost:8081/axis2/services/WebService" (RelFrameId=1)
    Action.c(6): \r\n
    Action.c(6): --MIMEBoundaryurn_uuid_68451DA92FDB4CD1DE12235648833 40
    Action.c(6): t=1143ms: 5-byte chunked response overhead for "http://localhost:8081/axis2/services/WebService" (RelFrameId=1)
    Action.c(6): \r\n
    Action.c(6): 2\r\n
    Action.c(6): t=1150ms: 2-byte chunked response body for "http://localhost:8081/axis2/services/WebService" (RelFrameId=1)
    Action.c(6): --
    Action.c(6): t=1154ms: 2-byte chunked response overhead for "http://localhost:8081/axis2/services/WebService" (RelFrameId=1)
    Action.c(6): \r\n
    Action.c(6): t=1159ms: 5-byte chunked response overhead for "http://localhost:8081/axis2/services/WebService" (RelFrameId=1)
    Action.c(6): 0\r\n
    Action.c(6): \r\n
    Action.c(6): Error -26612: HTTP Status-Code=500 (Internal Server Error) for "http://localhost:8081/axis2/services/WebService" [MsgId: MERR-26612]
    Action.c(6): t=1184ms: Closing connection to server localhost because server indicated that the connection should be closed [MsgId: MMSG-26000]
    Action.c(6): t=1188ms: Closed connection to localhost:8081 after completing 1 request [MsgId: MMSG-26000]
    Action.c(6): t=1190ms: Request done "http://localhost:8081/axis2/services/WebService" [MsgId: MMSG-26000]
    Action.c(6): web_custom_request("WebService_4") highest severity level was "ERROR", 884 body bytes, 429 header bytes, 23 chunking overhead bytes [MsgId: MMSG-26387]
    Ending action Action.
    -----------------------------------------------------------


    Does anyone has any idea what can be wrong?
    Thanks in advance ^ ^
    <font color="black"> </font>

  2. #2
    Member
    Join Date
    Dec 2007
    Posts
    85
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: HTTP status code=500 (Internal Server Error)

    check your server connection setting..

  3. #3
    Moderator
    Join Date
    Aug 2001
    Location
    NC
    Posts
    6,018
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Total Downloaded
    0

    Re: HTTP status code=500 (Internal Server Error)

    Possible causes for your '500'
    <ul type="square">[*]You likely need to add a SOAP header to your call.[*]Data is use once data and needs to be parameterized in the call[*]Data is in the wrong state for the action being requested[*]Application is in wrong state for the submission - bad data or bad correlation[*]You have a genuine application error[/list]

    Side Note: It seems odd that you are developing this script directly on the server (the localhost reference in your script).
    James Pulley

    Replace ineffective offshore contracts, LoadRunnerByTheHour. Starting @ $19.95/hr USD.

    Put us to the test, skilled expertise is less expensive than you might imagine.

    Twitter: @LoadRunnerBTH @PerfBytes

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 10.71%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 03:50 PM.

Copyright BetaSoft Inc.