User Tag List

Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2007
    Post Thanks / Like
    0 Post(s)
    0 Thread(s)

    Oracle NCA script hangs after connect

    ===== Begin Section for Copy/Paste to your Post =============
    1. What version of LoadRunner (LR) or PerformanceCenter (PC) are you using? (specify which tool LR or PC)
    LR 8.1 FP4

    2. What is the protocol you are recording?
    Oracle NCA

    2.1 If .NET, which version of .NET does the app require?

    2.2 If .NET, which version of .NET do you have installed?

    2.3 If OracleNCA with Oracle Forms Server, please list the version of Oracle Forms Server. You can get this info from the main Oracle Form when launched - Help -> About

    3. If HTML - are you using HTML-Advanced with URLs or,
    -A Script containing explicit urls only
    -Record in seperate steps and use concurrent groups

    4. If URL mode:

    5. Which LoadRunner/PerformanceCenter feature (FPs) or service packs are you using?

    6. VuGen Recording - are you using Old or New Recording Engine?

    7. What kind of LoadRunner license do you have -
    - Permanent/Unlimited

    8. If subscription, is subscription current or expired?

    9. What platform(s) (PCs) and Operating Systems (Windows-XP, etc.)? Include version and service packs (SP1 or 2, etc.)
    XP SP2

    10. If you have filed a service request with HP/Mercury, what have they told you at this point with respect to your issue?

    ===== End Section for Copy/Paste to your Post =============

    I'm creating an Oracle NCA script in a new environment and am having a problem with my script hanging. I'm at the point where
    I'm getting to steps that directly interact with the applicaton, but it hits the first nca_edit_set and just sits there forever.
    // these are the steps where the script hangs
    nca_edit_set("TEST_T123_0", "test2");

    I've let the script sit for 15 minutes before stopping it manually. With full logging on, I see no information about the nca_edit_set
    the only thing I see of interest in the logs are:

    vuser_init.c(98): t=9382ms: Closing connection to server sname1.ca.sname2 because server indicated that the connection should be closed [MsgId: MMSG-26000]
    vuser_init.c(98): t=9383ms: Closed connection to sname1.ca.sname2:443 after completing 1 request [MsgId: MMSG-26000]
    vuser_init.c(98): t=9383ms: Request done "https://sname1.ca.sname2:443/forms/lservlet;jsessionid=0d340adb63263f12d93e3f81afcf42 c6d0e35656a.e38Kbx4OaN10bxmOKbhqTe6fznA5Pp7ftolbGm kTy" [MsgId: MMSG-26000]
    vuser_init.c(98): Server Terminate Message: #5
    vuser_init.c(102): nca_set_window("Login")

    I've tried numerous things.
    1..The NCAJServSessionId is correlated. Prior to this the connect would directly fail.
    2..I've added the command web_set_sockets_option("SSL_VERSION", "3");

    and I ran into something on the support site talking about doing a recording that also included winsock and this code:
    lrs_create_socket("socket0", "TCP", "LocalHost=", "Backlog=1", LrsLastArg);
    port= lrs_get_socket_attrib("socket0", LOCAL_PORT);
    lr_output_message("port = %s", port);
    nca_java_set_option(JAVA_IPADDRESS, "");
    nca_java_set_option(JAVA_PORT, port);

    however, those arguments don't seem to exist for nca_java_set_option, at least in LR81FP4.

    The message "Server Terminate Message: #5" seems important, but something that confuses me, as a test I added a 'nca_get_top_window' and was surprised
    that it returned the fact that the window "Login" was on top, which is what my script expects. I figured the terminate message would mean
    the connection was totally lost.

    Any ideas on what is going on would be greatly appreciated.

  2. #2
    Moderator JakeBrake's Avatar
    Join Date
    Dec 2000
    St. Louis - Year 2025
    Post Thanks / Like
    0 Post(s)
    0 Thread(s)

    Re: Oracle NCA script hangs after connect

    Ensure you are using single protocol <font color="blue">Oracle Web Applications 11i</font>

    Within the script, wrap the nca_java_action(); statements within:
    <font color="brown">nca_step_begin(); </font>
    <font color="brown">nca_step_end(); </font>

    Locate and change the NcaTimerWaitMode values in the script folder's <font color="brown">default.cfg </font> file:

    Changing the NcaTimerWaitMode will delay the replay engine in searching for the item in case there is an active timer. This is disabled by default as it is not required in most of the cases. The NcaTimerWaitMode can be changed under the [NCA_GENERAL] section in the default.cfg file located under the script folder.


    where "value" is number from 0 to 3.

    NcaTimerWaitMode=0 The timer expired message is kept in the client message queue until next client terminate message. If an NCA replay function started its object search, but the object was not found and there is active timer in the system, replay waits for timer expiration, flushes the message queue by client terminate messages, and after an answer from a server, tries to find required object.

    NcaTimerWaitMode=1 When the NCA replay function is called and there is active timer in the system, always wait for its expiration, flush the message queue, and only then try to find the required object. This mode is useful when a required replay object already exists (no error on this step), but some requested data or form is not ready yet.

    NcaTimerWaitMode=2 When a client receives the timer schedule message, it just waits for requested time, generates an expired message, and sends it immediately. There are no messages between the server and client in this case.

    NcaTimerWaitMode=3 Differs from mode 1 by immediate message queue flush when an expired message is generated. This mode may be useful when there is no message flush due to NCA replay function execution.

    The nca_get_top_window function is called in a script. This function does not produces client messages, so, cannot flush message queue.

    Note:The default timer mode in LoadRunner 8.1 is set to 3. Hence, NcaTimerWaitMode=3 specifies the default mode in LR 8.1.

  3. #3
    Join Date
    Oct 2007
    Post Thanks / Like
    0 Post(s)
    0 Thread(s)

    Re: Oracle NCA script hangs after connect

    I'm not sure why you suggested the Oracle Web Applications Protocol as the forms server is 10.x, but I gave it a try and it basically crashed IE when it tried to load the applet.

    In the end, I managed to get in touch with someone who's worked in this environment, and I needed the NcaTimerWaitMode command that you mentioned. They suggested I add NcaTimerWaitMode=0, and I did (although I was surprised there wasn't even a NCA_General section in the file, I had to add it and the command.

    Seems to work now, although its still a bit buggy compared to the version I tested last time. All I had to do last time was add the correlation for the idx value, whereas in this case its remarkably picky regarding the steps at the beginning and end of the iteration.

  4. #4
    Junior Member
    Join Date
    Sep 2008
    Post Thanks / Like
    0 Post(s)
    0 Thread(s)

    Re: Oracle NCA script hangs after connect

    In my experience the NCA_General section of the file only shows up after you have attempted to replay the script.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 01:22 PM.

Copyright BetaSoft Inc.