SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 5 of 5
  1. #1
    Member
    Join Date
    Mar 2006
    Location
    Canberra
    Posts
    206
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    SAP Portal pdf not displaying

    1. What version of LoadRunner (LR) or PerformanceCenter (PC) are you using? (specify which tool LR or PC)
    LR 9.1

    2. What is the protocol you are recording?
    Web (HTTP/HTML)

    2.1 If .NET, which version of .NET does the app require?

    2.2 If .NET, which version of .NET do you have installed?

    2.3 If OracleNCA with Oracle Forms Server, please list the version of Oracle Forms Server. You can get this info from the main Oracle Form when launched - Help -> About


    3. If HTML - are you using HTML-Advanced with URLs or,
    HTML Based Script (Script containing explicit URLs only)

    4. If URL mode:
    - Concurrent groups, or
    - Without Concurrent groups?
    N/A

    5. Which LoadRunner/PerformanceCenter feature (FPs) or service packs are you using?
    N/A

    6. VuGen Recording - are you using Old or New Recording Engine?
    New

    7. What kind of LoadRunner license do you have -
    - Subscription,
    - Perpetual,
    - Permanent/Unlimited
    - Virtual User days, or
    - Evaluation?
    Permanent/Unlimited

    8. If subscription, is subscription current or expired?
    N/A

    9. What platform(s) (PCs) and Operating Systems (Windows-XP, etc.)? Include version and service packs (SP1 or 2, etc.)
    Windows XP (SP2)

    10. If you have filed a service request with HP/Mercury, what have they told you at this point with respect to your issue?
    No service Request lodged

    ************************************************** ********
    Hi,

    I've recorded a basic login to the SAP Portal and when I'm recording it all works fine (ie pdf of timesheet displays and is embedded in the portal). However, on playback I don't get any errors (after correlation) but the pdf is not displayed in Run-Time Viewer so I'm expecting it didnt work correctly. Is there any Runtime settins/recording Options I should have selected when recording the script. I've tried both a HTML & URL based script with the same results.

    The replay log has the text..
    Registering web_url("unknown.pdf") was successful

    Any ideas would be appreciated

    Thanks

    Gavin

  2. #2
    Junior Member
    Join Date
    Sep 2008
    Location
    Germany
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: SAP Portal pdf not displaying

    Hi,
    please check the following in your replay log.

    Do you notice anything like e.g.
    Action.c(xxxx): web_url("unknown.pdf") was successful, 22660 body bytes, 281 header bytes

    Please check if the body bytes match the size of your pdf.

    Another way to check whether the pdf is downloaded or not is to activate the extended logging. Then you should see a lot of binary data being downloaded from the server side.

    In general, I always deactivate the Runtime Viewer since I think it causes more trouble than it helps me in scripting...

    Cheers,
    guido

  3. #3
    Senior Member
    Join Date
    Oct 2004
    Posts
    1,011
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: SAP Portal pdf not displaying

    Run-Time Viewer is not full fledge browser..check PDF document download size for verification

  4. #4
    Member
    Join Date
    Mar 2006
    Location
    Canberra
    Posts
    206
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: SAP Portal pdf not displaying

    Thanks for the responses Guys. There does not appear to be a download size or at least one that I can see. The following line is displayed in the log

    Action.c(849): Registering web_url("unknown.pdf") was successful [MsgId: MMSG-26390]

    Are there any other options to verify that the embedded pdf has been displayed

    Thanks

    Gavin

  5. #5
    Moderator JakeBrake's Avatar
    Join Date
    Dec 2000
    Location
    St. Louis - Year 2025
    Posts
    15,609
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: SAP Portal pdf not displaying

    Refer to web_get_int_property(HTTP_INFO_DOWNLOAD_SIZE);

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.40 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 11.54%
vBulletin Optimisation provided by vB Optimise v2.7.1 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.3.0 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 01:32 PM.

Copyright BetaSoft Inc.