Results 1 to 6 of 6
  1. #1

    web services over HTTPS

    <font color="blue">1. What version of LoadRunner (LR) or PerformanceCenter (PC) are you using? (specify which tool LR or PC)
    LR, v

    2. What is the protocol you are recording?
    Web Services

    3. If HTML - are you using HTML-Advanced with URLs or,

    4. If URL mode:

    5. Which LoadRunner/PerformanceCenter feature (FPs) or service packs are you using?
    Feature Pack 4

    6. VuGen Recording - are you using Old or New Recording Engine?

    7. What kind of LoadRunner license do you have -
    - Permanent

    8. If subscription, is subscription current or expired?

    9. What platform(s) (PCs) and Operating Systems (Windows-XP, etc.)? Include version and service packs (SP1 or 2, etc.)
    MS Windows Server 2003, SP1

    10. If you have filed a service request with HP/Mercury, what have they told you at this point with respect to your issue?
    No SR to HP.</font>
    ================================================== =======
    Hi All,

    I am scripting for web services which communicates over HTTPS. I do not have a UI to record the communication. So apparently I am not getting any web_set_certificate(_ex) functions in the script. This is what my web_service_call looks like:

    "SOAPHeader=&lt;?xml version=\"1.0\" encoding=\"windows-1252\" standalone=\"no\"?"
    "&gt;&lt;h:BSCHeader xmlns:h=\"urn:CLIENTNAME.com:bsc.soap.BSCHeader:v2 .0\""
    "&gt;&lt;h:Authentication&gt;&lt;h:UserIdPasswordA uthentication&gt;&lt;h:UserID&gt;USERNAME&lt;/h:UserID&gt;&lt;"

    On running I get this error:

    <font color="red">Error: SSL protocol error when attempting to connect with host "hostname"</font>
    Notify: Saving Parameter "response = "
    <font color="red">Error: Web service call "STEP_NAME_102" execution failed</font>

    This is what I tried out: I exported the certificate from IE (in the PKCS #7 format), got it converted to PEM format using openssl and put in this function before the web_service_call:

    "CertFilePath=D:\Apps\Perfor~1\Defaul~1\Certs\abc_ cert.pem",

    But no luck. I even tried by putting the certificate in the LoadRunner certs directory but it didn't work. Is it the correct way to proceed? Did I miss something? Please let me know.

    <font color="blue">All limits are self-imposed.</font>

  2. #2
    Moderator JakeBrake's Avatar
    Join Date
    Dec 2000
    St. Louis - Year 2025

    Re: web services over HTTPS

    Try adding a web_add_header statement prior to your service call. Also, find out what kind of authentication is being used.

  3. #3

    Re: web services over HTTPS


    I talked to the developers and figured out that there wasn't any need to handle certificates in the script. The authorization info was being sent in the SOAP header itself. However, I used web_custom_request instead of web_service_call and the WinInet replay mode to get things moving for me. Guess this replay mode has its own scalability issues. The modified script looked somewhat like this:
    <font color="blue">
    web_add_header("SOAPAction", "https://HOSTNAME:6634/services/Imaging?wsdl");

    "Body=&lt;soapenv:Envelope xmlns:soapenv=\"http://schemas.xmlsoap.org/soap/envelope/\" "
    "xmlns:urn=\"urn:fdc:CLIENTNAME.com:2007:esb.xxxxx x\"&gt;&lt;soapenv:Header&gt;&lt;h:BSCHeader "
    "xmlns:h=\"urn:CLIENTNAME.com:bsc.soap.BSCHeader:v 2.0\"&gt;"
    "&lt;h:Authentication&gt;&lt;h:UserIdPasswordAuthe ntication&gt;&lt;h:UserID&gt;USERNAME&lt;/h:UserID&gt;"
    "&lt;/h:Authentication&gt;&lt;/h:BSCHeader&gt;&lt;/soapenv:Header&gt;&lt;soapenv:Body&gt;&lt;urn:yyyy yyyy&gt;"

    <font color="#666666">-thanks &amp; regards,
    <font color="blue">All limits are self-imposed.</font>

  4. #4

    Re: web services over HTTPS


    We are a bit stuck on this. The script is running fine for ~55 users. But when we start ramping up users beyond that, the vusers start failing and I get this error message:

    <font color="red">Error -27492: "HttpSendRequest" failed, Windows error code=12017 (cannot connect) and retry limit (0) exceeded for URL="https://HOSTNAME:6634/services/Imaging</font>

    This is a Mule ESB server that we are hitting. Did some research around the Windows error code and found this for error code 12017: "The operation was canceled, usually because the handle on which the request was operating was closed before the operation completed".

    Could this be related to the WinInet replay mode (though I doubt it)? Or is it perhaps due to some limitations of the ESB (concurrent threads, retry limits)?

    Please share your valuable thoughts.

    <font color="blue">All limits are self-imposed.</font>

  5. #5

    Re: web services over HTTPS

    Can you check the support site I remember having seen some thing on this error code.Also google this forum,I think someone over there had given some solution for this error code.

  6. #6

    Re: web services over HTTPS

    Done that Kiranbadi. I found this for the issue: http://www.sqaforums.com/showflat.php?Ca...true#Post118193 which is exactly the same as the only reply in the HP support forum.

    <font color="blue">All limits are self-imposed.</font>



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
BetaSoft Inc.
All times are GMT -8. The time now is 07:31 PM.

Copyright BetaSoft Inc.