SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Mar 2007
    Posts
    29
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Do you have to have at least one Assoc. Func. lib

    Basically I am trying to *not* have our hundreds of tests dependent on a specified location of an associated library (in File->Settings (Resource tab) in case we have to change that location for some reason....then we will have to change the association in File->Settings for those hundreds of tests. So I am running an initialization script using a drive letter to find the script that will be defined in an enviornment variable. This works fine....well almost! If I do not have *any* resources listed in File->Settings (Resource tab) then I get a Run Time error. If I list something then it works fine...no errors. Even if I list something bogus as long as I list something....why is that? Does it automatically look for something listed and if there is nothing it assumes you must have made an error?

  2. #2
    Moderator
    Join Date
    Jul 2005
    Location
    Delhi
    Posts
    15,575
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    7 Thread(s)
    Total Downloaded
    0

    Re: Do you have to have at least one Assoc. Func.

    The thing that i follow is not to have any path in test setting files. So instead of the below

    [QualityCenter] Subject\Automation\Common\LoaderModule.vbs
    [QualityCenter] Subject\Automation\Common\DataDriver.vbs

    The File->Settings would look something like below
    LoaderModule.vbs
    DataDriver.vbs

    And my Tools->FolderOptions would look like
    [QualityCenter] Subject\Automation\Common

    Though this makes me dependent on the QTP folder configuration but my scripts are pretty independent and can be run from any folder path just by changing the configuration.

  3. #3
    Junior Member
    Join Date
    Mar 2007
    Posts
    29
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Do you have to have at least one Assoc. Func.

    Ok...I can live with that. I still don't understand why I have to put something there. I should have the option of not listing anything.

    Thanks Tarun...this was very helpful [img]/images/graemlins/smile.gif[/img]

    The "Wendin8tor"

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 12.50%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 02:35 AM.

Copyright BetaSoft Inc.