I have a list of description objects in a .vbs file and functions in a .qfl file.Both of these files are uploaded to resources of qc.the functions are using those description objects. While using the test only on qtp, without using qc, i can able to use that .vbs file using ExecuteFile method . But while using qc this is not working. Especially I face this type of problem in BPT. i add both of the files in the application area and i am able to get the test resources i.e. the description objects in scripted component but not in the function library. Can you please tell me what to do in this situation. i tried that for sample flight application also there also I face the same problem. A part of those files i'm giving belo.


Set loginDlg=Description.Create
Set uid=Description.Create
uid("attached text").Value="Agent Name:"
Set pwd=Description.Create
pwd("attached text").Value="Password:"
Set acptBtn=Description.Create


Function OpenApp()
On Error Resume Next
InvokeApplication "C:\Program Files\HP\QuickTest Professional\samples\flight\app\flight4a.exe"
If Dialog(loginDlg).Exist Then
End If
If Err.Number<>0 Then
End If
End Function

Both of these file are uploaded in qc. While writing the script, pressing Ctrl+Space, I am able to get the objects like loginDlg but not in function library. i tried the ExecuteFile method also but is not working

Can anybody tell me what to do to solve this problem