SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1
    Junior Member
    Join Date
    May 2003
    Location
    Boston, MA, USA
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Installation error, QC 9.2 td user default pwd

    I spent time searching the archives and found a few posts similar to mine, but they did not provide a resolution. Apologies in advance if this is a repeat post.

    We are experiencing challenges installing QC 9.2 for the first time in the following configuration:

    QC Sever = Linux
    QC DB Server = MSSQL Server on Windows

    We worked through a number of issues and thought that the installation was running successfully until the following error occured:
    <font class="small">Code:</font><hr /><pre> com.mercury.optane.core.CTdException

    Messages:
    CMSSQLCreator : Unable to create database dbHPTD;
    <font color="red"> Unable to add login 'td'; </font>
    [Mercury][SQLServer JDBC Driver][SQLServer]Password validation failed. The password does not meet Windows policy requirements because it is too short.;
    </pre><hr />

    I am surmising from this error message that the installation is trying to create the user "td" in the SQL Server database with an embedded default password that does not meet the security requirements for my particular organization.

    My question is:

    Can I modify the td user's default password BEFORE that installation to something that will pass the security test for passwords?

    Thank you for your time.

    -Aaron Cook
    Collaborative Consulting

  2. #2
    Junior Member
    Join Date
    May 2003
    Location
    Boston, MA, USA
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Installation error, QC 9.2 td user default pwd

    Just to update things. It turns out that we were dealing with a security policy on the SQL Server. We tried to manually create the td user with the default password and could not get the installer to behave.

    We ended up shifting to using Oracle as our back-end database. The install performed flawlessly. Go figure...

    -Aaron

  3. #3
    Senior Member
    Join Date
    Jul 2008
    Posts
    160
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Installation error, QC 9.2 td user default pwd

    Hi Aaron,

    The issue was pretty easy to resolve. When you install QC, it asks for the database details during the installation wizard. Here you give the name of the DB server, the DB admin username and password. Now if you click on the show advanced options, it has user called the QC user which has a default password. This is by default tdtdtd. Issue is woth the security policy of SQL2005. Username is td which is repeated in the password. If you change the QC user password to something like Welcome*123 and proceed with the installation, it finishes without any errors

    I just joined the forum today so couldnt answer it on time, else you could have used SQL without any issues [img]/images/graemlins/smile.gif[/img]

    Regards,
    Richa.

  4. #4
    Member
    Join Date
    Jan 2008
    Posts
    44
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Installation error, QC 9.2 td user default pwd

    Hi All,

    I am facing the error as " User td already exists in the current DataBase". Has any one faced this problem before?

    Thanks.

  5. #5
    Senior Member
    Join Date
    Jul 2008
    Posts
    160
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Installation error, QC 9.2 td user default pwd

    Hi,

    we had a similar problem. We uninstalled the SQL server. Reinstalled it with SP1 (as ours was a SQL 2005 server). Install completed successfully.

    Regards,
    Richa.

  6. #6
    Member
    Join Date
    Jan 2008
    Posts
    44
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Installation error, QC 9.2 td user default pwd

    Hi,

    Installation went fine this time... after i changed the td settings to the databases. But when i try to log in to the site admin, it is not accepting the one which i gave during the installation. I gave the same id which i used for QC9.0 during the installation. Where can i check the user name and password for site admin. Is there any way to reset the password of site admin login?

    Thanks in advance.

  7. #7
    Senior Member
    Join Date
    Jul 2008
    Posts
    160
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Installation error, QC 9.2 td user default pwd

    Hi Aaron,

    To reset the site admin password is simple:

    1. On the database qcsiteadmin_db, go to the USER_ROLES table. Here note the UR_USER_ID for the user whose UR_ROLE_ID is 10.
    2. Now go to the USERS table. Here set the US_PASSWORD=NULL where US_USER_ID is the one you noted down in step 1.
    3. Now login to Iste Admin with this username and a null password.

    Regards,
    Richa

  8. #8
    Member
    Join Date
    Jan 2008
    Posts
    44
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Installation error, QC 9.2 td user default pwd

    Hi Richa,

    I did the same thing. I am able to find three users in the USER_ROLES table with role_id 10. I changed the password for all the three users to &lt;NULL&gt;. And i stopped and started the application server also. After which i tried to log in to the Site Admin. I am getting the same error. Here is the error.

    "Failed to Login;
    Failed to Check authentication of user 'admin';
    Cannot build directory item for key
    '[qcsiteadmin_db@jdbc.mercury.sqlserver://dwbdsapcn01:1433(td)]' in SA Global Struct Dir;
    Failed to fill table struct for table null in database'qcsiteadmin_db@jdbc.mercury.sqlserver://dwbdsapcn01:1433(td);[Mercury][SQL Server JDBC Driver] Unsupported VM Encoding Cp936;"

    Please help me to find a solution. Thanks in advance.

  9. #9
    Senior Member
    Join Date
    Jul 2008
    Posts
    160
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Installation error, QC 9.2 td user default pwd

    Hi Aaron,

    Please let me know are you using LDAP authentication or QualityCenter authentication?

    Regards,
    Richa

  10. #10
    Member
    Join Date
    Jan 2008
    Posts
    44
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Installation error, QC 9.2 td user default pwd

    Hi Richa,

    We are using the Quality Center authentication.

    Thanks.

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 10.71%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 09:22 AM.

Copyright BetaSoft Inc.