Results 1 to 2 of 2
  1. #1
    New Member
    Join Date
    Jan 2015
    Belgrade, Serbia, Serbia

    Failed to enter a string into textbox (WPF application)

    In WPF application I have two text box fields - first field property is a isReadOnly=False and second textbox has property isReadOnly=True. While recording a keyword tests in first field I enter some string, leave second as it is and then I hit save button.

    When I try to replay that test texbox where it needs to be typed that string has been skipped and the value tried to enter that other field which property is isReadOnly=true. Test fails with explanation " Failed to enter text in edit box,since it is a read only".

    Seems like ID's of those text fields are dynamic. Do you have any idea what to do with that.

    So I tried with different approach - I used FindObject. In FindObject I entered a textbox class name property and isReadOnly=false property. It didnt found any methods under it, so I guessed that some other stuff is going on - I got an error message Alias. ... .parentObject of textbox cannot be found.

    What to do with that...?? Do you have any idea?

  2. #2
    parentObject of textbox cannot be found
    Seems TestComplete not able to find the parent object itself to find the text boxes you have mentioned. Try to check whether the parent elements exists or not before accessing the child text boxes. Hope you will solve.

    Thank/Like to help others if my input helped you !!!
    I am speaking for myself, not for my employer nor any one.
    Automation Ecstasy



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
BetaSoft Inc.
All times are GMT -8. The time now is 05:58 PM.

Copyright BetaSoft Inc.