Results 1 to 3 of 3
  1. #1

    unrecognized object


    I have a problem with TestComplete. Our problem is with the names of the components when I run my application in hand, we have in the object tree an object named WPFObject ( "HwndSource: Main") which contains in its tree all the components of our application .
    If I run my application from TestComplete using TestedApp, the object named WPFObject ( "HwndSource: Main") is now called Windows ( "HwndWrapper [GC.Application.exe ;;........ ] ") and contains nothing we can not interact with the components of our application.
    Have you an explanation to this problem?


  2. #2

    Re: unrecognized object

    Hello Laetitia,

    What version of TestComplete are you using? I recommend that you use the latest one. TestComplete 7.51 is available for downloading from our web site and from the ClientServices portal.

    If you still face the issue with the latest version, please provide us with additional information regarding the problem:

    1. Please clarify in what way you run the application: by using the TestedApps.Run method or by clicking the tested application node in the Project Explorer. In case you are running your application in RunAs mode, please refer to the "Settings Required for Testing Open Applications in RunAs Mode" help topic and make sure that you are using correct settings.
    2. Please try increasing the value of the Method invoke timeout option (see the "Project Properties - General Open Applications Options" help topic) and let me know whether it helps.
    3. Please try refreshing the target process within the Object Browser (right-click the node of the process and select Refresh). Does this help?
    4. In case neither increasing the Method invoke timeout option, nor refreshing the application's process helps, please send us the list of DLLs that are loaded by your application when it is not open for TestComplete. This can be easily done with Process Explorer. It's a FREE tool that can be downloaded from http://www.microsoft.com/technet/sys...sExplorer.mspx
      It doesn't require installation - just run the procexp.exe executable.
      Please follow the steps below:

      1) Launch TestComplete, your application and Process Explorer;
      2) In Process Explorer:
      - select the application's process in the upper sub-window;
      - press Ctrl+D or the "View DLLs" toolbar button to switch to DLL mode;
      - save the contents of the lower sub-window (File | Save As...).

    Thanks in advance.
    Best regards,
    David - SmartBear Support

  3. #3

    Re: unrecognized object


    Thank for your response, I send a mail of support with a Attachment file the list on DLLs that are loaded by my application.




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
BetaSoft Inc.
All times are GMT -8. The time now is 04:00 PM.

Copyright BetaSoft Inc.