SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 3 of 3
  1. #1
    Senior Member
    Join Date
    Nov 2008
    Posts
    119
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Tc 7.10 not recognizing name mappings

    So prior to updating to version 7.10 I have 497 successfully running scripts. Now i am writing a script, however when I run it it will not find my aliases object. It always searches for this text field by the field's Property name...and not the object name I provided.

    For example..it looks for "txtfieldedit" instead of the alias I provided. It always logs that it cannot find the object. Sometimes It will eventually find the object and type in the field, but still logs the error.

    Any idea? This was working find in TC 7, but not in 7.10.

    I can do a record, take the EXACT thing recorded and put it in my test and it fails. If I get to the screen and run the recording, sometimes it passes and sometimes it fails.

    I'm simply trying to get it to type in a field. So it looks something like:

    Call Aliases.Buyer.Edit.Keys("^aName")

    Any ideas why this is failing when in previous scripts written under 7 it worked just fine?

    I am moving my aliases up under a shorter parent object. I have tried leaving them where they are, and moving up with no avail.

    Thanks

  2. #2
    Senior Member
    Join Date
    Nov 2008
    Posts
    119
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Tc 7.10 not recognizing name mappings

    So I figured out my problem after about 2 hours of playing around and then posting here and thought i'd post back in case someone else had the same problem.

    In projects in the past when name mapping I would have to add some additional information for it to identify.

    With the SAME fields on the SAME screens prior to the TC 7 update it was seeing the fields needed. Now it is not, so when mapping, i have to add "name" to the list as well.

    Hope this helps!

  3. #3
    Senior Member
    Join Date
    May 2004
    Posts
    1,196
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Tc 7.10 not recognizing name mappings

    Hi Dana,

    So, do you mean that objects in your application are not recognized as Open by TestComplete 7.10? Please let me know in what programming language your application is written and post here your project along with results of the failed execution or send it to us via the Contact Support form (http://www.automatedqa.com/support/message/). We will look into the issue.
    Best regards,
    David - SmartBear Support

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 11.54%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 02:17 AM.

Copyright BetaSoft Inc.